Partial Outage
Incident Report for Catalyst
Resolved
This incident has been resolved.
Posted Oct 09, 2023 - 10:42 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 01, 2023 - 17:14 EDT
Identified
The Catalyst application is not loading or currently has degraded performance for some customers. We've identified the issue and are working to resolve it.
Posted Sep 29, 2023 - 22:15 EDT
This incident affected: Website.