Partial Outage
Incident Report for Catalyst
Resolved
This incident has been resolved.
Posted Nov 27, 2023 - 12:04 EST
Update
The Catalyst application is not loading or currently has degraded performance for some customers.
Posted Nov 27, 2023 - 10:19 EST
Monitoring
We found the problem and a fix is in the works. Monitoring the solution for further impact.
Posted Nov 20, 2023 - 18:16 EST
Identified
The Catalyst application is not loading or currently has degraded performance for some customers. We've identified the issue and are working to resolve it.
Posted Nov 20, 2023 - 12:50 EST
This incident affected: Website.